WordPress 2.0.7 Released

WordPress 2.0.7 has been released. The major focus of this release was a new security patch under certain versions of PHP with register_globals turned on, plus a fix in Conditional GET support under certain combinations of IIS/PHPCGI versions (AKA the “Feedburner bug”). There are a few other minor bugfixes in there, as well.

You can download the new version here